cenos7安装spug监控主机及执行任务记录


python manage.py initdb时出现报错

报错1 django.core.exceptions.ImproperlyConfigured: SQLite 3.8.3 or later is required (found 3.7.17).

解决方法 期间有个软连接太多的报错如下,先删除软连接再建软连接 rm

ln -s: failed to access Too many levels of symbolic links

rm /usr/bin/sqlite3 再用绝对路径建 ln -s /usr/local/sqlite/bin/sqlite3 /usr/bin/sqlite3

pip安装库时出现报错

pip install pyldap 报错:lber.h:没有那个文件或目录

解决方法

安装nodejs方法参考,记得版本要对哦

前端yarn安装

-bash: yarn: command not found

解决方法 :

  1. 安装 npm install -g yarn
  2. 修改 path export PATH=/usr/local/nodejs/bin/:$PATH